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Editora Casa
Dedico este livro a minha esposa,
pelas horas que lhe roubei ao escrevê-lo.
“A mente que se abre a uma nova ideia
jamais voltará ao seu tamanho original.”
Albert Einstein
INTRODUÇÃO
Estamos vivendo uma revolução! Isso mesmo, uma revolução. A Terceira Revolução dos livros!
A Primeira Revolução se deu com a invenção dos tipos móveis, por Gutenberg. Até aquele momento, os livros eram copiados à mão, sobretudo pelos monges, visto que a plebe era analfabeta e os nobres (letrados) estavam ocupados demais com as intrigas palacianas. As ferramentas para a produção literária se resumiam a um tinteiro, uma pena e rolos de papiro1.
Com a invenção de Gutenberg, foi possível a criação da Imprensa, produzindo livros de forma massificada.
O processo de produção de livros se manteve praticamente inalterado desde Gutenberg até o século XX e a Segunda Revolução dos Livros só foi possível após a criação do computador. O grande nome desta revolução é bem conhecido ainda hoje por todos: Adobe Systems.
O famoso formato PDF que hoje já faz parte do nosso dia-a-dia foi criado e vem sendo desenvolvido pela Adobe há mais de vinte anos. O formato é bastante versátil, sendo amplamente utilizado na Web. O seu uso no compartilhamento on-line, no entanto, não é o que tange à Revolução mencionada. O PDF é hoje o formato padrão exportado pelos programas de design gráfico. Ele é a “matriz” que vai para a “prensa”, por assim dizer.
O PDF caiu nas graças dos designers por um simples (e maravilhoso) motivo: o que você vê na tela é o que vai ser imprenso e, por conseguinte, é o que vai chegar ao leitor. O designer tem controle absoluto na apresentação do livro. Por esse motivo, ele tem reinado soberano por todos esses anos.
A computação, todavia, evoluiu. De máquinas que ocupavam andares inteiros há algumas décadas, hoje temos computadores que cabem na palma da mão. Temos Desktops, Notebooks, Tablets, e-Readers, Smartphones, etc.
A portabilidade criada por essa nova gama de eletrônicos abriu caminho para um novo tipo de publicação: o e-Book, o livro digital. Imagina carregar toda a sua biblioteca com você durante suas viagens?
O primeiro formato adotado para os livros digitais foi obviamente o PDF, que já era amplamente utilizado nos computadores pessoais. Praticamente todo equipamento eletrônico dotado de uma tela é capaz de ler arquivos nesse formato.
Entretanto, o maior trunfo do PDF, seria agora também sua grande desvantagem nesse novo cenário: o layout fixo. Quando o designer cria um PDF para a impressão, ele sabe de antemão todos os detalhes do livro a ser imprenso. Ele então cria todo o projeto gráfico com base nas dimensões do livro alvo, bem como o tipo de papel e outros detalhes. Eis o “problema” dos livros digitais: eles não tem uma dimensão fixa; suas “dimensões” são dadas pelo tamanho da tela do dispositivo.
A leitura de ebooks em PDF se torna impraticável em dispositivos com tela pequena, uma vez que as letras ficam muito pequenas. Como resolver isso?
A solução veio com a utilização do mesmo mecanismo já utilizado nos Websites: HTML/CSS. A linguagem HTML permite criar textos fluidos, que se adaptam ao dispositivo que o está exibindo. Além da adaptação, ele permite maior liberdade ao leitor: podemos alterar as fontes utilizadas, o tamanho do texto, as margens, as cores, etc.
Utilizando-se dessa linguagem, foi criado pelo IDPF um novo padrão para ebooks: o ePub. Ele traria à tona a Terceira Revolução dos Livros, a qual estamos vivendo hoje com a crescente popularização dos livros digitais. Este formato aberto foi rapidamente adotado pelo mercado editorial eletrônico. Existem também formatos proprietários como o Mobi, da Amazon (além de outros). A diferença está nessas palavras: aberto e proprietário. Enquanto o Mobi é de uso exclusivo da Amazon (Kindle), o ePub pode ser utilizado por qualquer empresa, pois é um formato aberto. Este foi o formato adotado pela Apple, por exemplo, no seu Ibooks (aplicativo de leitura nativo do iOS).
Agora que já sabemos do que se trata o formato ePub, que tal aprendermos a criar um livro nesse formato? Afinal, foi com essa intenção que você começou a leitura desse Tutorial, não é mesmo?
Mãos à massa!
CAPÍTULO I
AS FERRAMENTAS2
A princípio, um ePub pode ser criado do zero apenas com um editor de texto. Até o Bloco de Notas do Windows já serviria. Este seria, no entanto, um trabalho um tanto maçante e pouco eficiente. Sendo assim, vamos à lista das ferramentas que iram tornar nossa tarefa bem mais simples:
1) Atlantis Word Processor: Editor de texto semelhante ao MS Word. O diferencial é que ele tem a capacidade de exportar o texto para o formato ePub.
2) Sigil: Editor de arquivos ePub, bastante funcional e fácil de se utilizar.
3) KindleGen: Esse é um bônus! Com ajuda dele, o Atlantis irá também exportar o texto para o formato Mobi. Todavia, não iremos editar o arquivo Mobi gerado.
4) MS Word: Utilizado para correções no texto, durante a fase de preparo.
Os programas 2 e 3 são gratuitos e podem ser baixados no link indicado. O Atlantis, no entanto, custa US$35,00 atualmente. Um preço bem em conta.
CAPÍTULO II
PREPARANDO O ARQUIVO DE TEXTO ORIGINAL
Para a produção do nosso ebook, precisamos do arquivo de texto original num formato editável, ou seja: TXT, DOC, DOCX, RTF ou ODT. Todos esses formatos podem ser abertos no Atlantis.
Caso seu arquivo seja um PDF, primeiramente será necessário convertê-lo3 para um desses formatos.
1. Escolhendo o arquivo fonte
Antes de começar a criar o ePub, é preciso prestar um pouco de atenção ao arquivo de texto original. O ideal é que este arquivo esteja o mais bem formatado possível, de preferência já com os Estilos aplicados. Se você não sabe o que são Estilos, não se assuste. Mais abaixo irei explicar como utilizá-los.
Portanto, corra de arquivos danificados (quebras de linha no meio das frases, por exemplo). Evite também arquivos com muitos erros de OCR4. Arquivos assim podem gerar um trabalho quase tão grande quanto o de digitar o texto novamente. Estamos querendo agilidade, então é preferível substituir a fonte. Pequenos erros são aceitáveis e será ensinado como corrigi-los.
2. Preparando o arquivo fonte
Uma vez que já se dispõe de um arquivo razoável, procede-se ao seu preparo no editor de texto (Atlantis). É de suma importância que o arquivo seja devidamente ajustado antes de se iniciar a edição do texto propriamente dita.
Antes de mais nada, ative a opção “Special Symbols” no menu “View”. Após ativada essa opção, o texto ficará cheio de símbolos. Esses símbolos são marcas de formatação5. Elas vãos nos ajudar a obter um melhor controle durante a edição.
2.1 Corrigindo duplo espaçamento
Este procedimento visa remover espaços excessivos por conta de erros de digitação. Vamos indicar um toque na barra de espaços pelo símbolo %.
Tecle CTRL+F no teclado. Na caixa de diálogo que aparece, clique no campo FIND WHAT e apague qualquer coisa que estiver escrito. Em seguida, tecle duas vezes a barra de espaços. Depois, clique no campo REPLACE WITH e tecle uma vez a barra de espaços. Resumindo: FIND (%%) e REPLACE (%) Agora é só clicar em REPLACE ALL. Ele irá fazer uma varredura do texto e depois irá perguntar se quer repetir. Vá clicando sempre em YES, até que aparece a mensagem de que foram substituídas X palavras.

Figura 01
2.2 Corrigindo o uso de travessões
Em alguns textos, é comum a utilização do caractere “-” no lugar de “—”. Para corrigir isso de maneira automática, proceda da seguinte maneira: FIND (^p-) e REPLACE (^p^+). Clique em REPLACE ALL. Clique em YES até que apareça que foram feitas X substituições. Isso irá corrigir os travessões no início dos diálogos.
Para corrigir os travessões dentro das frases — como nos casos de explicações como esta —, utilize na sequência, esses dois comandos: FIND (%-%) e REPLACE (%^+%); FIND (%-,) e REPLACE (%^+,).
2.3 Corrigindo entradas de lista no lugar de travessões (MS Word)
Ao escanear um texto, o programa de OCR tenta colocar no arquivo uma cópia fidedigna do que estava na imagem escaneada. No entanto, ele pode fazer escolhas que nos atrapalham. Uma delas é a seguinte: são usadas entradas de lista com o símbolo “-” ou “—” nos parágrafos com diálogos. Visualmente, o texto parece normal. No entanto, ao zerar a formatação (passo mais a frente), esses símbolos vão sumir. Caso não limpemos a formatação, ainda assim teremos problemas o ePub.
Para evitar esse problema, criei uma Macro que resolve o problema em 99% dos casos. Se você não sabe usar Macros, pode pular essa parte ou se informar a respeito. A Ajuda do MS Word pode ser útil.
Vamos ao código da Macro:
Sub ReplaceBullets()
Dim oPara As Paragraph
Dim r As Range
Dim sParaStyle As String
For Each oPara In ActiveDocument.Paragraphs()
Set r = oPara.Range
If r.ListFormat.ListType = wdListBullet Then
sParaStyle = oPara.FirstLineIndent
r.ListFormat.RemoveNumbers NumberType:=wdNumberParagraph
r.InsertBefore Chr(151) & " "
oPara.FirstLineIndent = sParaStyle
End If
If r.ListFormat.ListType = wdListOutlineNumbering Then
sParaStyle = oPara.FirstLineIndent
r.ListFormat.RemoveNumbers NumberType:=wdNumberParagraph
r.InsertBefore Chr(151) & " "
oPara.FirstLineIndent = sParaStyle
End If
Set r = Nothing
Next
End Sub
2.4 Corrigindo espaço extra no fim ou no início dos parágrafos
Para corrigir um espaço extra no começo dos parágrafos ou no fim, use respectivamente os seguintes comandos: FIND (^p%) e REPLACE (^p); FIND (%^p) e REPLACE (^p).
2.5 Outras correções
Caso sejam necessárias outras correções, use a caixa de diálogo FIND / REPLACE para as correções.
CAPÍTULO III
EDITANDO O TEXTO
Agora que o arquivo já está preparado, estamos prontos para começar a edição do texto, através da aplicação de Estilos. No entanto, vamos antes revisar algumas noções importantes.
1.Conceitos iniciais
Os editores de texto trabalham com dois tipos de formatação: por parágrafos (através dos Estilos) ou por caracteres.
Caractere é cada letra, número ou símbolo do texto.
Parágrafos são as unidades macro de formatação de um texto. Um novo parágrafo é iniciado sempre que se pressiona a tecla ENTER no teclado. O final de um parágrafo se dá também pelo uso da tecla ENTER e é indicado pela sua marca característica (
).
Ao editarmos palavras individuais, ou mesmo parte delas, estamos formatando apenas os caracteres, e as alterações possíveis são mais limitadas: mudar a cor do texto, mudar a cor do fundo, colocar em itálico ou negrito, sublinhado, etc. No entanto, não é possível alterar, por exemplo, o espaçamento entre linhas, nem o alinhamento do texto. Para uma edição mais ampla, devemos editar os parágrafos do texto. Sempre que possível, deve-se evitar a formatação de caracteres. Isso por que qualquer alteração feita no caractere, só poderá ser desfeita (ou alterada) manualmente, item a item, enquanto a alteração de um Estilo de parágrafo irá afetar todos aqueles existentes no texto, automaticamente.
Além de evitar a formatação de caracteres, é uma boa prática nunca utilizar o ENTER como forma de criar espaços entre os parágrafos. Caso um determinado parágrafo precise ser isolado do anterior por um espaço, e essa seja uma exceção que não justifica criar outro estilo, faça o ajuste do parágrafo no menu “Fomat > Paragraph”. Escolha um valor diferente de zero para os itens SPACING > BEFORE e SPACING > AFTER. Para criar uma linha branca, utilize 14 pt.
Esse recurso visa garantir que o espaço seja realmente respeitado pelo aplicativo de leitura. Utilizar o ENTER, nem sempre terá esse efeito (alguns e-Readers irão ignorar esses espaços).
2. Utilizando Estilos
Estilo é um conjunto de regras (formatação) predeterminado que pode ser aplicado a qualquer parágrafo. Um ebook possui vários Estilos, sendo que cada um se aplica a um determinado tipo de parágrafo. Exemplo: O texto principal do livro, geralmente é justificado e possui um recuo diferenciado na primeira linha (chamada indentação); já os títulos dos capítulos, costumam ser centralizados e em negrito.
Para a utilização de Estilos, é preciso criá-los antes. Os Estilos também podem ser importados de outro documento já formatado: nesse caso, caso abra o documento novo e também o já formatado; selecione o documento novo; selecione o menu “Format > Style > Import”; marque o documento de onde quer importar os Estilos; selecione os Estilos que quer importar; clique em “Ok”.
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3. Criando Estilos
Primeiramente, é conveniente que se habilite a aba de Estilos: “View > Control Board”. A nova aba possui no seu topo duas opções de visualização importantes: Índice e Estilos.
Com esta aba aberta, poderemos ir aplicando os estilos a cada parágrafo. Além disso, alternando para o Índice, poderemos ver o ebook tomando forma. O Índice será gerado automaticamente.

Figura 04
Para criar um novo Estilo, clique no ícone
na nova aba que foi habilitada. Será aberta uma nova caixa de diálogo. Dê um nome ao seu Estilo. Em seguida faça as alterações referente àquele estilo em questão. Vejamos um exemplo.
3.1 Criando o Estilo “normal”
FONT: Adobe Garamond Pro; Tamanho 12 pt.
PARAGRAPH: Justificado; indentação de 0,85pt; espaçamento entre linhas de 1,4; espaçamento antes e depois do parágrafo igual a 0.
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Vejamos item a item dentro da opção PARAGRAPH:
ALIGNMENT (Alinhamento): A opção justificado deixa o texto alinhado nas margens direita e esquerda.
OUTLINE LEVEL (Nível do parágrafo): A opção BODY TEXT diz que o parágrafo faz parte do texto normal. Essa opção deve ser modificada somente no caso de títulos, itens e subitens, mudando para LEVEL 1 para o primeiro título, LEVEL 2 para um item dentro do título, etc. O uso desses níveis é que irá criar o Índice automaticamente, como mostrado na Figura 04.
INDENTS (Indentação): Colocar em 0 as opção LEFT e RIGHT. Na opção FIRST LINE, escolha INDENT e coloque o valor de 0,85 pt.
SPACING (Espaçamento): As opções BEFORE e AFTER definem o espaço antes do parágrafo e depois do mesmo, respectivamente. A opção LINE SPACING define o espaçamento entre linhas. Um bom valor é 1.4.
3.2 Criando os demais Estilos
Crie os demais estilos de acordo com a necessidade do texto. Veja os exemplos de estilos que criei nesse Tutorial.
4. Aplicando Estilos
Para aplicar os Estilos ao texto, devemos clicar no parágrafo a ser formatado (basta clicar em qualquer ponto do parágrafo; não precisa selecionar o parágrafo todo) e depois dar um duplo-clique no Estilo criado (na lista de estilos, na aba da esquerda).
Para facilitar, no caso de um texto grande como de um ebook, é melhor zerar a formatação e começar do zero. Para isso, selecione todo o texto e aplique o Estilo “normal”. Isso por que esse será o estilo utilizado na maior parte do texto.
Em seguida, vá aplicando os Estilos criados ao texto.
5. Inserindo Notas de Rodapé
O seu ebook pode conter informações extras que não fazem parte do fluxo do texto. Essas informações poderão ser colocadas em Notas de Rodapé.
Veja que o conceito de Nota de Rodapé é oriundo dos livros físicos. Como o próprio nome disse, essa Nota virá no Rodapé da página. O conceito de página, entretanto, é mais flexível nos livros digitais fluidos, como aqueles no formato ePub. A página só existe em um estado latente em um ePub. Ela somente será criada pelo leitor, ao escolher o dispositivo de leitura (e alterar margens, tamanho das letras, etc.).
Sendo assim, não podemos fixar a posição das Notas de Rodapé da maneira convencional. Mas não se preocupe, o Atlantis lida com isso de forma automática. Ele cria um arquivo com todas as Notas e o acrescenta no final do livro. Essas Notas funcionam através de links que levam do texto para a nota e vice-versa.
Para inserir uma Nota de Rodapé, posicione o cursor no ponto do texto em que será criada a referência (um número sobrescrito). Em seguida, vá ao menu “Insert > Footnote”. Ajuste as opções como na Figura 07.
Ao clicar em INSERT, você será levado ao rodapé da página. Copie o texto da nota neste espaço. Caso o texto original já esteja formatado adequadamente com as Notas de Rodapé, o Atlantis irá reconhecê-las.

Figura 07 – Inserindo Notas de Rodapé
6. Separando os Capítulos
Um passo importante durante a edição do texto é a inserção de quebras de página entre um capítulo e outro. Uma quebra de página faz com que o próximo item comece em uma nova página. Assim, cada capítulo vai sempre começar no início da página, o que é recomendado.
Para inserir uma quebra de página, posicione o cursor após a última palavra do capítulo atual e tecle CTRL+ENTER. O cursos irá saltar para a próxima página e, na página anterior, irá aparecer uma linha pontilhada com a inscrição PAGE BREAK.
7. Correção Ortográfica
Um vez que já estamos com o texto pronto, é o momento de passar o texto pelo corretor ortográfico. Sugiro que esse passo seja feito no MS Word, visto que o Atlantis não possui corretor em PT-BR. No site, você pode baixar apenas um corretor em PT-PT.
8. Adicionando uma Capa
O texto do seu ebook já está pronto. A única coisa que está faltando é a Capa.
Para criar uma capa, basta adicionar uma imagem na primeira página do ebook. Após a imagem, crie uma quebra de página. Em seguida, ajuste a imagem para a página inteira. Esta imagem será utilizada automaticamente para ser a capa do seu ebook.
CAPÍTULO IV
EXPORTANDO O EPUB
Após a edição do texto, com todos os Estilos devidamente aplicados, temos um ebook pronto para ser exportado. Vejamos como fazer isso.
Vá ao menu “File > Save especial > Save as ebook”. Escolha o nome do arquivo e o local onde será salvo. Em seguida, será apresentada uma caixa de diálogo, solicitando informações adicionais sobre o livro.
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1. Metadados e fontes
Os dados solicitados nessa caixa de diálogo serão utilizados para compor os metadados do ePub. Os metadados são lidos pelos programas de leitura, permitindo que a sua coleção de livros seja organiza por gênero, autor, título, etc. Além disso, você pode adicionar uma breve descrição do livro, que também será mostrada em programas de gerenciamento de biblioteca, como o Calibre.
Perceba que em COVER IMAGE, já foi selecionada aquela imagem colocada na primeira página.
Na opção FONTS, é recomendável que se escolha a opção SAVE AND EMBED, caso queira que as fontes utilizadas sejam incorporadas ao ebook, garantindo que ele será visualizado como você planejou. Caso você esteja preocupado com o tamanho do arquivo, pode escolher SAVE, BUT DON’T EMBEB. Neste caso, a fonte será identificada no arquivo, mas não será incorporada. A visualização do ePub irá depender de dois fatores no final: o programa de leitura e as fontes disponíveis no sistema.
Caso o programa de leitura seja capaz de usar a fonte definida, e ela esteja presente no sistema, o texto será visualizado como planejado. Entretanto, caso a fonte não esteja disponível no sistema, o programa de leitura irá designar uma fonte padrão para o texto.
Cabe ressaltar que mesmo com a fonte incorporada ao ebook, alguns programas teimam em ignorar essa informação e usam suas fontes pré-definidas. Isso ocorre com o Ibooks e com o Adobe Digital Editions, por exemplo. Outros programas, como o Calibre, respeitam a informação e o texto é visualizado como planejado.
Após preencher os dados, podemos clicar em OK e o arquivo ePub será gerado. Agora só falta alguns ajustes finos que serão feitos através do Sigil.
2. Bônus: exportando no formato Mobi
Seguindo os passos descritos acima, você terá exportado o arquivo no formato ePub. Caso também queira o arquivo no formato Mobi, precisamos antes baixar o aplicativo KindleGen.
O aplicativo não precisa ser instalado. Basta extrair o arquivo “kindlegen.exe” e salvá-lo na pasta do Atlantis (C:\Arquivos de Programas (x86)\Atlantis).
Uma vez que o aplicativo está nesta pasta, basta seguir os mesmos passos do item anterior durante a exportação. A diferença é que agora serão sempre exportados dois arquivos distintos, o ePub e o Mobi.
CAPÍTULO V
EDITANDO O EPUB
O arquivo exportado no capítulo anterior já está totalmente funcional, com capa e índice. No entanto, ainda podemos fazer alguns pequenos ajustes, aparando as arestas deixadas pelo Atlantis, que apesar de ser muito eficiente, nos deixa refém de seus padrões em certos casos (não podemos controlar o layout da capa ou editar o índice, por exemplo). Esse refinamento deve ser feito através do Sigil, editando o próprio ePub exportado anteriormente.
1. Abrindo o ePub no Sigil
Antes de mais nada, abra o programa e vá ao menu “Edit > Preferences”. Na caixa de diálogo que se abre, selecione a opção LANGUAGE. Modifique ambas as opções para PORTUGUESE – BRAZIL. Reinicie o aplicativo.
Para abrir o ePub, vá ao menu “Arquivo > Abrir” e selecione o arquivo de texto original.
2. Elementos do Sigil

Figura 09 – Tela inicial do Sigil
O Sigil está divido em 3 partes: na esquerda, vemos a estrutura interna do ePub (que será detalhada mais a frente); no centro, temos a visualização do ebook; na direita, temos o Sumário.
Na aba da esquerda, temos diversos arquivos. Cada um deles pode ser aberto através de um duplo clique do mouse. O arquivo aberto será visualizado no painel central. Na Figura 09, o arquivo aberto é o “001.html”, que corresponde à capa gerada pelo Atlantis. Podemos abrir os arquivos também ao clicar nos itens do Sumário.
Por fim, podemos alternar o modo de visualização: clique no menu “Visualizar” e escolha entre “Visualizar Livro” ou “Visualizar Código”.

Figura 10 – Modo “Visualizar Código”
Na Figura 10, podemos ver o mesmo arquivo “001.xhtml”, que é a capa, em forma de código.
3. Preparando o Sigil antes da edição
Antes de começarmos a editar, vamos conhecer uma ferramenta muito útil no Sigil: os Clips.
Um Clip é um texto padrão que você sempre irá utilizar nos seus livros e, portanto, não quer ficar digitando tudo de novo toda vez que for criar um novo livro.
Para habilitar a guia de Clips, vá ao menu “Visualizar > Clips”. Agora os Clips vão aparecer no canto esquerdo inferior, abaixo a estrutura do ePub.
Para criar um Clip, vá ao menu “Ferramentas > Editor de Clip”. Na caixa de diálogo que surge, clique em “Adicionar entrada”. Dê um nome para o seu Clip, algo que tenha a ver com a função dele No campo da esquerda, digite o texto que irá compor o Clip.

Figura 11 – Criando Clips
Para utilizar um Clip, basta clicar no seu nome no painel que foi habilitado anteriormente (no canto inferior esquerdo).
A princípio, você não terá ideia do que colocar em um Clip. Por isso, seguem dois Clips muito úteis na edição de ePubs. Mais à frente você verá como são uteis.
3.1 Clipe de Capa
<div style="text-align: center; padding: 0pt; margin: 0pt;height: 99.9%; width:99.9%">
<svg xmlns="http://www.w3.org/2000/svg" height="99.5%" preserveAspectRatio="xMidYMid meet" version="1.1" viewBox="0 0 616 925" width="99.5%" xmlns:xlink="http://www.w3.org/1999/xlink">
<image height="925" width="616" xlink:href="../Images/cover.jpg"></image>
</svg>
</div>
Este Clip será utilizado para formatar as capas.
3.2 Clip auxiliar “No margin”
<style type="text/css">
@page {padding: 0pt; margin:0pt}
body { text-align: center; padding:0pt; margin: 0pt; }
</style>
Este clipe será utilizado em qualquer página que você não queira nenhum tipo de margem, deixando o conteúdo ocupar todo os espaço disponível. Será sempre utilizado na formatação da Capa.
4. Estrutura do ePub
Um arquivo ePub não é nada mais que um arquivo ZIP contendo uma série de pastas recheadas de arquivos. No entanto, este não é um ZIP comum. Ele obedece a uma estrutura pré-definida, que é o que garante que ele será lido corretamente pelos e-Readers. Vejamos essa estrutura em detalhes.
4.1 Arquivos estruturais
Os arquivos estruturais não são visualizados pelo leitor, mas são utilizados pelo aplicativo de leitura.
O arquivo “content.opf” é um manifesto de toda estrutura interna do ePub, listando todos os arquivos inclusos, além de listar as propriedades de cada arquivo. O arquivo da Capa, por exemplo, está marcado com a seguinte tag: <reference href="Text/001.html" title="Cover" type="cover" />.
Esta tag sinaliza para o aplicativo de leitura, que aquela é a Capa do livro, e portanto será exibida na sua Estante Virtual. Caso essa tag não esteja presente, o aplicativo de leitura irá definir uma capa. O Calibre faz isso pegando a primeira imagem disponível no texto, ou criando uma imagem à partir da primeira página do texto. No caso do Ibooks, ele irá criar uma daquelas capas marrons/azuis/cinzas imitando um livro capa dura com o título e o autor escrito sobre ela.
Esta tag é criada automaticamente pelo Atlantis.

Figura 12 – Estrutura interna do ePub
O arquivo “toc.ncx” é o Índice do livro. Este índice não faz parte do texto. Ele será usado para criar o Índice disponível ao aplicativo de leitura, que servirá para a navegação durante a leitura.
OBS.: Os arquivos estruturais não devem ser modificados por iniciantes, sob o risco de gerar ebooks defeituosos.
4.2 A pasta TEXT
Dentro desta pasta, estarão os arquivos que formam o texto do livro propriamente dito. Cada arquivo, representa um capítulo ou um item individual (como Capa, Contracapa, Índice, Dedicatória, Epígrafe, etc.).
A divisão em arquivos menores, cada um para um capítulo, é de suma importância. Caso todo o livro fosse deixado em um único arquivo, poderia ocorrer lentidão e/ou travamentos durante a leitura, isso por que o aplicativo de leitura teria de lidar com arquivos muito grandes.
Se olhar com atenção, verá que a divisão em arquivos corresponde às quebras de página inseridas no Atlantis durante a edição do texto. Veja que elas têm um papel fundamental!
4.3 A pasta STYLES
Dentro dessa pasta, estão as folhas de estilo disponíveis. A folha “cover.css” pode ser removida, pois iremos o utilizar o Clip criado para a formatação da Capa.
Já a folha “styles.css” contém toda a formatação do texto. Ela é criada automaticamente pelo Atlantis com base nos Estilos definidos no Capítulo III. Este é um dos arquivos mais importantes do livro. Por não ser o escopo deste Tutorial, não entrarei em detalhes sobre a formatação da folha de estilos. A linguagem usada é a CSS (Cascading Style Sheet – Folha de Estilos em Cascata). Quem quiser mais informações, um ótimo site sobre o assunto é o Site do Maujor.
4.4 A pasta IMAGES
Esta pasta irá agrupar todas as imagens disponíveis no ePub. A Capa estará ali com o nome “cover.jpg” ou algo do tipo.
Neste ponto, podemos conferir se a tag de capa (mencionada no item 4.1 deste capítulo) foi devidamente criada: clique com o botão direito sobre o arquivo “cover.jpg”; vá em “Adicionar Semântica > Imagem de capa”. Caso já esteja marcado, não precisa fazer nada; senão, basta clicar em “Imagem de capa”.
4.5 A pasta FONTS
Caso tenha optado por incorporar as fontes utilizadas ao ePub, elas estarão nesta pasta.
Do contrário, esta pasta estará vazia.
5. EDIÇÃO: Ajustando a Capa
Inicialmente, podemos perceber que a capa gerada pelo Atlantis aparenta estar distorcida. Na verdade, ela não está distorcida, como pode ser observado ao abrir o ePub com um aplicativo de leitura. No entanto, ela ainda não está com a formatação ideal.
Ao criar a capa, o Atlantis simplesmente coloca a imagem no centro da página, mantendo suas dimensões originais. Caso a imagem seja muito grande, ela poderá aparecer cortada ou dividida em duas páginas durante a visualização do ePub.
Para corrigir isso, iremos utilizar os Clips criados nos itens 3.1 e 3.2, deste capítulo.
Primeiramente, vamos abrir o arquivo da capa (001.html). Em seguida, alterne para o modo Visualização de Código (tecle F2).

Figura 13 – Código original gerado pelo Atlantis
Com o arquivo aberto, posicione o cursor no final da linha <link href="../Styles/cover.css" rel="stylesheet" type="text/css"/> e tecle ENTER. Agora, clique no Clip “No margin” criado no item 3.2, disponível na lista de Clips no canto inferior esquerdo da tela.
Em seguida, apague tudo que estiver entre as linhas <body> e </body>. Depois, posicione o cursor ao final da linha <body> e tecle ENTER. Insira agora o Clip “Capa”, criado no item 3.1.
Resta agora corrigir as dimensões reais da figura. Vejam que o Clip “Capa”, tem os valores padrões de 616x925. No entanto, esse valor pode não corresponder às reais dimensões da sua imagem. No caso deste ebook, por exemplo, temos uma Capa com dimensões de 720x960 pixels.
Devemos então alterar esses valores. Altere, primeiro o atributo viewbox (viewBox="0 0 616 925"). Mude de 925 para 960 e de 616 para 720.
Agora mude os valores de WIDTH e HEIGHT, respectivamente para 720 e 960. Atenção pois a ordem agora está invertida.
O resultado final é este:

Figura 14 – Código final para o arquivo de Capa
6. EDIÇÃO: Ajustando o Índice
Este é o nosso último passo. Estamos quase lá.
Nem sempre há muito o que ajustar. Além disso, alguns podem estar satisfeitos com o resultado automático do Atlantis. Mas vejamos como podemos alterar o Índice gerado.
OBS.: No caso desse ebook, utilizei no Estilo “Heading 1” a propriedade SMALL CAPS para as fontes. Esse efeito é conhecido como VERSALETE no MS Word. O texto fica todo em “maiúsculo” (as letras maiúsculas de fato, ficam um pouco maior). Um contratempo desse recurso é que o ÍNDICE será criado todo em maiúsculo para o Nível 1.
Selecione o menu “Ferramentas > Sumário > Edit Table of Contents”. Na caixa de diálogo que se abre, dê um clique duplo nos títulos para poder editá-los.
Caso queira remover alguma linha ou criar uma nova, utilize as opções ADD ABOVE, ADD BELOW e DELETE para, respectivamente, criar uma linha acima, abaixo, ou deletar.
Quando adicionar uma nova linha, digite um título (que irá aparecer no Índice) e depois clique em SELEC TARGET. Na lista que se abre, escolha o arquivo para o qual irá apontar o link.

Figura 15 – Índice gerado pelo Atlantis
Selecione o menu “Ferramentas > Sumário > Edit Table of Contents”. Na caixa de diálogo que se abre, dê um clique duplo nos títulos para poder editá-los. Caso queira remover alguma linha ou criar uma nova, utilize as opções ADD ABOVE, ADD BELOW e DELETE para, respectivamente, criar uma linha acima, abaixo, ou deletar.
No nosso caso, iremos fazer as seguintes alterações: mudar a entrada “Página de título” para “Capa”; acrescentar uma entrada para a “Folha de Rosto”; e ajustar os títulos dos capítulos que estão em maiúsculo.

Figura 16 – Índice revisado
7. EDIÇÃO: Salvando o ePub
Chegamos ao fim da nossa edição do ePub. Temos agora um livro digital apresentável, muito bem acabado.
Para salvar o arquivo final, vá no menu “Arquivo > Salvar”.
Pronto, seu ePub já está pronto para ser lido!
POSFÁCIO
Este tutorial é um projeto antigo. Sempre quis fazê-lo, mas me faltava a coragem de começar. Por fim, criei coragem e comecei. A princípio, iria digitá-lo diretamente no corpo da mensagem no Fórum. No entanto, percebi o quanto ficaria incompleto e optei por criar o ebook. O ebook não apenas ficou mais organizado, como também servirá como material para teste para aqueles que querem verificar a aplicação dos conceitos explicados aqui.
O leitor tem em suas mãos, o arquivo RTF editado no Atlantis, bem como o ePub final. Com o RTF aberto, o leitor poderá observar passo-a-passo as instruções ao longo do texto. No final, poderá exportar um ePub ainda não revisado e proceder à revisão conforme as instruções. Por fim, poderá comparar o seu arquivo final com este aqui.
Em tempo, quero pedir desculpas pelos possíveis deslizes gramaticais e/ou ortográficos. Não sou um Escritor e, muito menos, disponho de um Editor para a fazer a revisão. Este é o trabalho de um amante da leitura, feito de Leitor para Leitor.
Caso ainda restem dúvidas quanto ao que foi aqui exposto, me coloco à disposição para atendê-los na medida do possível. Envie suas dúvidas por e-mail no thiago.eec@gmail.com .
Sem mais, obrigado a todos que tiveram a paciência para chegar até aqui. Espero que tenha valido a pena!
Thiago Oliveira
Goiânia, 28 de Novembro de 2013.
{1} O romance “O nome da Rosa” de Umberto Eco nos dá uma ideia sobre a produção literária na Idade Média.
{2} As ferramentas acima são indicadas para a criação de ePubs simples, focados no texto. O Atlantis não suporta tabelas, por exemplo. Para a criação de ePubs profissionais, um programa mais apropriado é o Adobe Indesign.
{3} Para a conversão, pode ser utilizado o MS Word. Ao tentar abrir o documento, ele te dará a opção de tornar o arquivo editável. No final, é só salvar uma versão em DOC ou DOCX.
{4} OCR – Optical Character Recognition (Reconhecimento Ótico de Caracteres) é o processo de conversão de imagens (livro escaneado) para texto editável.
{5} Veja mais sobre marcas de formatação clicando aqui.
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